Wednesday, September 21, 2005

Drag and drop won't work

The problem:-For some inexplicable reason drag and drop has stopped working.

The Resolution:-If some one faces the above problem in Windows XP then I shall suggest him to do the followings:-
1]Sometimes just a system reboot solves the issue.So try that first.


2]Check whether Drag and Drop is enabled or not.Right click on Start button>Properties>Start Menu>Customize>Advanced>Under the start menu items make sure the box against Enable dragging and dropping is checked.

3]If the above fails then try a System Restore.

4]If nothing helps,then type the following commands from the Run menu.:-

i>Start>Run>type in-"regsvr32 ole32.dll "(without the quotes)>press the Enter Key or OK.
ii>Start>Run>type in-"regsvr32 /i shell32.dll "(without quotes)>press the Enter
Key,or,OK.

5]Restart the computer.

17 comments:

frank said...

Your advice worked well. Thanks again!

ssg said...

Glad to know.Happy computing.

mpm01285 said...

Just wanted to say thanks, 4 weeks ago I had this same problem with my drag and drop and couldn't use my defrag wouldn't work. I search the net for days to find an answer and couldn't find one. So I wiped out my hdd and reloaded xp. Well it happened again today and was all set to wipe out the drive again and I thought I'd try the net one last time and I found your blog entry from 9/21/05 and used4]If nothing helps,then type the following commands from the Run menu.:-

i>Start>Run>type in-"regsvr32 ole32.dll "(without the quotes)>press the Enter Key or OK.
ii>Start>Run>type in-"regsvr32 /i shell32.dll "(without quotes)>press the Enter
Key,or,OK.
rebooted my system and all is well again. Thnksa you saved me 12 hrs. of reinstalls

jayne.mcdonald said...

The regsvr worked a treat - thanks very much!

Tota said...

I don't have any idea how this problem appeared on my client's computer, but after finding silly "solutions" on several sites, I found your blog and the "regsvr" hack worked like a charm. Thanks, you saved me a Windows reinstall!
Cheers

Em said...

ditto for me. this problem appeared after i cleaned out my registry, and 4] solved my problem.

thanks!!

Housepet Magazine said...

this worked for me too. thanks so much... MY other question is, the XP is not shutting down. i am still having troubles with IE and Firefox too (links wont open from web pages)Also... I downloaded some trial versions of design softwares. they wont run and work... this all started when i refused to renew NOrton for $60. Norton was giving me pop ups and I couldnt uninstall or get rid of it. Whne I finally called the company, they made me download an uninstaller. However, I am left with a messed up system. Any advice is greatly appreciated.

Glycerine said...

Thank you so much - Its such a daft error, your not sure where to start - Its an issue that I'll know how to fix again.

Thanks again!

Revolution_i3Di said...

last instruction works for me ;)

Dave Ho said...

Hi, I have the same problem with a 2K PC dose your fix apply to 2K? Thanks Dave

Sy said...

Hi is there any service or process that can be restarted to avoid rebooting? I usually have lots of things I'm working on when this happens. Thanks!

CosMind said...

well, this issue popped up for me after windows auto-updated to xp service pack 3 mid last week. the only suggestion of yours that fixed the problem was a system restore back before service pack 3 was installed. is this a general service pack 3 bug? if so, is there news as to when it may be resolved so that i can update my os to the latest service pack and still be able to drag and drop files?

thanks in advance!

CosMind said...
This comment has been removed by the author.
CosMind said...
This comment has been removed by the author.
CosMind said...
This comment has been removed by the author.
Mark said...

Thanks for your help on this problem! I was ready to reinstall windows and then I found your fix. You saved me alot of time! Thank you.

piotrekgabriel said...

Well, none of these ways worked, BUT I googled, that it could have something to do with iexplore. So, I installed ie7 and it worked ;)